rpm check all packages
rpm -V $(rpm -qa) > packagecheck
My work, my view, and my imagination

rpm -V $(rpm -qa) > packagecheck
It was reported as BUG 649550 on Redhat Bugzilla that some users complained that they could not establish a graphical connection to their servers since when they log in with ssh -X or ssh -Y, the terminal spitted out an error that it cannot lock ~/.Xauthority file. This issue has been out there for years […]
When Serial ATA600 hard drives are plugged in a RAID controller that supports only SATA150 and SATA300, since the controller cannot understand what SATA600 is, to be defensive, it automatically default the communication ratio down to its low margin, SATA150. However, given the performance drop, now-a-day SATA600 drives are no longer backward compatible with SATA150. […]
When using Fedora installed in a virtualbox VM to remote connect to a linux host, some applications may crush when opening a menu with the error “failed to create XIM input context”. This is because VirtualBox does not handle scim well. A simple workaround is to put in a line export QT_IM_MODULE=gcin in the .bashrc […]
To the public knowledge, this is caused by missing 127.0.0.1 localhost line in your /etc/hosts file. However, for some applications, even if you have that line, you will still get this error. Or what if you do not have access/privilege to modify the /etc/hosts file? There is still a work around: Suppose the affected program […]
Modern DHCP server will identify clients using its MAC address, such that if you are offline (shutdown the client computer) for a short period, like a few hours, up to a few days, depends on the load of the dhcp server and the pool size, when you are back online again, you will get the […]
First the system has the following system mounting points /proc, /sys, /dev, /dev/shm, /dev/pts, mounted properly. However, in some OS, the file /usr/libexec/pt_chown has the permission -rws–x–x This seems not working in the chroot subsystem. By changing the permission of the file /$chroot_root/usr/libexec/pt_chown to -rwsr-xr-x screen works in chroot system.
command $(cat filelist)
sed ‘:a;N;$!ba;s/\n/ /g’ infile > outfile
The fix for this is pretty easy and clear – just do #unset DISPLAY before ssh-ing.